Announcement

Collapse
No announcement yet.

GLX error when launching Abaqus on Debian

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GLX error when launching Abaqus on Debian

    Hi everyone,

    Since I upgraded Nvidia drivers on Debian jessie/sid to version 340.65, the following shows up everytime I launch Abaqus :

    Code:
    X Error: code 2 major 155 minor 3: BadValue (integer parameter out of range for operation).
    fmd_GLContext::create(): glXCreateContext() failed.
    terminate called after throwing an instance of 'nex_PrimException<ipc_IPCMsgErrorTypeEnm, 1>'
    Abaqus Error: Abaqus/CAE Kernel exited with an error.
    I googled the error message for hours, in vain.
    Has anybody here faced the same issue ?

    Thanks in advance.

    PS :*using the -mesa flag solved it, but who would forget about hardware acceleration when they just moved from Quadro FX 3450 to GTX 780

  • #2
    I agree with your frustration ;(
    Unfortunately I don't have the answer.
    On my Ubuntu box I use the following command: " XLIB_SKIP_ARGB_VISUALS=1 abaqus cae -mesa ", not pretty but helps.

    -Jorgen
    Jorgen Bergstrom, Ph.D. PolymerFEM Administrator

    Comment


    • #3
      Thanks Jorgen for the quick reply.

      I use the very same command to launch Abaqus
      Hopefully a future update of nvidia-driver will solve this…

      Cheers.

      Comment


      • #4
        We had the issue in our department and could bypass the Exception by using VirtualGL.
        I just had to install VirtualGL (std. ubuntu repository) and can start CAE now by
        vglrun abaqus cae
        (+ the translucent fix environment var..).

        The issue was really annoying, as it occured with a Quadro Fx4800, a K420 and a Quadro5000 and all Nvidia driver from 304+.
        Now it works perfectly!

        Comment


        • #5
          Test your X server by running "glxinfo -i". If this fails with a similar error, it means that indirect OpenGL rendering is disabled. Abaqus /CAE needs to be able to create an indirect rendering context for printing. Make sure the "AllowIndirectGLXProtocol" option in the server configuration is set to True (add if needed) and you may need to start the server with "+iglx" on the command line if it otherwise defaults to "-iglx".

          Comment


          • #6
            Many thanks, solved the issue for me. No need for MESA! Running on NVIDIA natively

            Originally posted by mrees View Post
            Test your X server by running "glxinfo -i". If this fails with a similar error, it means that indirect OpenGL rendering is disabled. Abaqus /CAE needs to be able to create an indirect rendering context for printing. Make sure the "AllowIndirectGLXProtocol" option in the server configuration is set to True (add if needed) and you may need to start the server with "+iglx" on the command line if it otherwise defaults to "-iglx".
            In more detail for ubnutu (16.04 in my case): http://askubuntu.com/questions/74513...ith-nvidia-gfx

            Simply add +iglx to the line: xserver-command=X -core +iglx in /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf

            Comment

            Working...
            X