Search
Close this search box.
Notifications
Clear all

pure deformation of linear elastic body

4 Posts
2 Users
0 Reactions
444 Views
Posts: 4
Topic starter
(@liuaea)
New Member
Joined: 16 years ago

Dear, Dr. Jorgen

Im in trouble.

I have been trying to carry out simple calculation of pure shear deformation of liner [I]hypoelastic[/I] body in finite strain.

However, in my FE analysis, the body deform very strangely and I have never been able to find what is the problem because the subroutine is too simple.

I attach the input and user material subroutine file I wrote.

I have a plan to calculate pure shear deformation of polymer using elasto-viscoplastic constitutive equation based on molecuar chain network theory proposed by Dr. Mary C. Boyce. However, without solution of this simple problem, I wouldnt be able to step forward.

If you can answer to this problem, please tell me what is wrong in these files.

Sincerely yours,

Topic Tags
3 Replies
Posts: 3998
(@jorgen)
Member
Joined: 5 years ago

First, why are you starting with a hypoelastic material model if you are ultimately thinking about switching to a hyperelastic type model?

I would start with a hyperelastic model and then add the viscoplasticity.
I wrote a simple [URL= http://polymerfem.com/forums/showthread.php?t=42 ]VUMAT[/URL] for the Neo-Hookean model that you can use as a template.

-Jorgen

Topic Tags
3 Replies
Posts: 4
Topic starter
(@liuaea)
New Member
Joined: 16 years ago

Thanks for your reply, Dr. Jorgen

Sorry for my unclear question. I really need your help. Since I

would like to let you understand my situation, I try to make detailed

explanations as follows.

First, I want to perform the FE simulation with ABAQUS/Explicit

based on a rate form of a constitutive model. So I understand this model

is a relationship between the objective stress rate and the stretching

tensor. Simply speaking, this model can be derived from the hypoelastic

material. I can not change the model.

I wrote a user material subroutine based on the model and perform

some simualtions. It works under a tension and a compression, BUT I have

a trouble on a pure shear. Even if I do not consider the plastic part,

i.e. the model is for a pure elastic, I still have the trouble under the

pure shear. I attached the subroutine.

I read the subroutine again and again and for many times. I could

not still found my mistake.

Im so happy if you will help me.

Reply
Posts: 3998
(@jorgen)
Member
Joined: 5 years ago

Oh, I see. Your modeling framework sounds just fine. My suspicion is probably the same as your, that there is likely some bug in the model implementation. Unfortunately, debugging a VUMAT is a very time consuming activity, and I simply dont have the time for that work as part of my free support.

Send me a private message if you want to discuss professional (payed for) support.

- Jorgen

Reply
Share: