Search
Close this search box.
Notifications
Clear all

[Solved] PolyUMod Error: At least 17 material parameters are needed

5 Posts
3 Users
3 Likes
451 Views
Posts: 12
Topic starter
(@aviva)
Eminent Member
Joined: 2 years ago

Hi, I am tring to import the PolyUMod to ls-dyna. I follow the tutorial on the website. I load the .k from the MCalibration in dyna without any modification. It is loaded successfully. When calculating, there is a mistake.

I cannt find any guide to solve the PolyUMod Error.

Hope to get your help. Thanks a lot.

4 Replies
Posts: 12
Topic starter
(@aviva)
Eminent Member
Joined: 2 years ago

We need to import the PolyUMod material by copying and pasting in k. file by .txt editor.  Sometimes loading the PolyUMod .k file from ls-dyna as tutorial, dyna will change the names of Material Parameters so that PolyUMod cannot recognize them. So there will be the errors above.

Reply
Posts: 3998
(@jorgen)
Member
Joined: 4 years ago

All you need to do is to copy the k-file commands generated by MCalibration right into the LS-DYNA k-file that you want to analyze. Note that all PolyUMod material models start with 16 global parameters, so the error you got indicates that you did not copy all MCalibration generated commands.

Feel free to share your commands if you still have problems making it work.

/Jorgen

Reply
Posts: 3998
(@jorgen)
Member
Joined: 4 years ago

One more thing. You can also ask for technical support by directly emailing to: support at polymerfem dot com.

/Jorgen

Reply
Posts: 5
(@valeryanpilov)
Active Member
Joined: 2 years ago

Good evening,

Unfortunately, I also met this error.

Maybe this error can be corrected by matching the data format in both programs?

Reply
Share: