Search
Close this search box.
Notifications
Clear all

Zero stress in damage model implemented with VUMAT

3 Posts
2 Users
0 Reactions
575 Views
Posts: 17
Topic starter
(@thegiving21)
Active Member
Joined: 8 years ago

Hi all,
I implemented an isotropic damage model in Abaqus/Explicit using VUMAT subroutine for quasi-brittle materials. The analysis completed successfully but when I want to see the results I found that there is zero stress, but I get the correct force-displacement curve with softening behavior. It should be noted that in this case the code included if ( stepTime .eq. 0 ) then .
When I delete if ( stepTime .eq. 0 ) then from the code, I get the non-zero stress in the output, but I find that the material behavior is elastic. I did not understant how if ( stepTime .eq. 0 ) then can influence the behavior and the results. Can anyone give an explanation of this ? and how can I get non-zero stress with softening behavior of the force-displacement ?

Thank you all!!

Topic Tags
2 Replies
Posts: 80
(@FrankMonkey)
Trusted Member
Joined: 15 years ago

Subscribe to and seek assistance from the
ABAQUS mailing list
[url] https://groups.yahoo.com/neo/groups/Abaqus/info [/url]
Search the archive of the list before posting in it.
The list does not accept attachments.

Or
[url] http://www.eng-tips.com/threadminder.cfm?pid=799 [/url]
or from the ResearchGate discussion forum.

For an intro to subroutines get the file
[url] http://imechanica.org/files/Writing [/url] User Subroutines with ABAQUS.pdf

Good luck

Frank

Topic Tags
2 Replies
Posts: 17
Topic starter
(@thegiving21)
Active Member
Joined: 8 years ago

Can anyone give me a response to my question ?!

Reply
Share: