Search
Close this search box.
Notifications
Clear all

A question about linking ABAQUS and FORTRAN

3 Posts
3 Users
0 Reactions
509 Views
Posts: 3
Topic starter
(@togsandclogs)
New Member
Joined: 12 years ago

i am a P.H.D Candidate in Iran University of Sience and Technology (www.iust.ac.ir)

recently i try to use VUMAT Subroutine in ABAQUS

but in this way i had a lot of problems

for solving those problems i tried some solution

at first i saw a problem that ifort.exe is not found in path

i solved this problem with these method

1) install visual studio 2010

2) install intel fortran compiler (composer) 2011 update 3

3) install abaqus 6.10

then i change target command abaqus to

C:\Program Files (x86)\Intel\ComposerXE-2011\bin\ifortvars.bat intel64 && D:\SIMULIA\Abaqus\Commands\abq6101.bat cae || pause

by using this method i could solve that problem which is related to ifort.exe is not found in path

but after this , i encounterd with another problem that is

Problem during linking - Single Precision Abaqus/Explicit User Subroutines.

This error may be due to a mismatch in the Abaqus user subroutine arguments.

These arguments sometimes change from release to release,

so user subroutines used with a previous release of Abaqus may need to be adjusted.

and i could not solve this problem

please help me

Best Regards

Amin Khajehdezfuly

Iran, Tehran, IUST University

Topic Tags
2 Replies
Posts: 1
(@nilsing)
New Member
Joined: 12 years ago

Hi,
I am Tarbiat Modares university Student and i have the same problem.
May i ask you if you have solved your problem please tell me about it?
Thanks alot

Topic Tags
2 Replies
Posts: 7
(@johking17)
Active Member
Joined: 12 years ago

Hi Amin,

I had met one unknown problem which was similar yours. I solved it by uninstalling visual studio 2010 and installing visual studio 2008.

Maybe you can try this.

Good Luch!
Best Regards
Ziguo

Reply
Share: